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Introduction

The GlassFishTMServer is an open source Application Server that implements the Java EE
platform. It is the industry standard for implementing enterprise-class Service-Oriented
Architecture (SOA) and next-generation web applications.

The Eclipse is a popular open source Integrated Development Environment (IDE) that is widely
adopted in the developer community.

The GlassFish Tools Bundle for Eclipse is a software bundle that includes GlassFish Server v3,
Eclipse IDE 3.5.x and the plug-in that enables them to work together. It provides a ready-to-use
IDE environment that helps you get started with developing applications on Eclipse and
deploying them to GlassFish Server.

In addition, GlassFish Tools Bundle for Eclipse Release also includes Metro Web Services Stack
plug-in and Maven plug-in for Eclipse.

This document helps GlassFish Tools Bundle for Eclipse users to become familiar with using
the product and its various features. The document contains information on the following
topics:

■ Installing GlassFish Tools Bundle for Eclipse
■ Configuring and Using GlassFish Server from IDE
■ Developing Applications for GlassFish Server
■ Using Java EE 6 Wizards
■ Getting Started with Metro
■ Using Popup Menu
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Installing GlassFish Tools Bundle for Eclipse

This chapter describes the process of installing GlassFish Tools Bundle for Eclipse on different
platforms.

Installation
■ “To Install on Windows Platform” on page 9
■ “To Install on Mac OS Platform” on page 10
■ “To Install on Linux Platform” on page 11
■ “To Install on Open Solaris Platform” on page 13
■ “To Uninstall” on page 15
■ “Troubleshooting” on page 15

▼ To Install on Windows Platform
Download Windows version of GlassFish Tools Bundle for Eclipse package from the following
location:

http://download.java.net/glassfish/eclipse

Double click the downloaded file, to start Installer wizard.

Welcome Message is displayed.

Click Next.

License Agreement is displayed.

Read and accept License Agreement. Click Next.

2C H A P T E R 2
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Accept default location or select a different location to install software.
For example: C:\GlassFish-Tools-Bundle-For Eclipse-<version>\

Click Install.
Wait for installation to complete.

Click Close.

To start the IDE, select Start->Programs->GlassFish Tools Bundle for Eclipse
<version>->GlassFish Tools Bundle for Eclipse.
Workspace Launcher wizard is displayed.

Accept the default Workspace location or enter a different location.

Click OK.
GlassFish Registration page is displayed.

Register GlassFish Server from Registration page.
You can also choose one of the other registration options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish depending on the option you chose in the previous screen.
The IDE is opened.

Close Welcome page to enter the default Workbench, in Java EE Perspective.

▼ To Install on Mac OS Platform
Download Mac OS version of GlassFish Tools Bundle for Eclipse from the following location:
http://download.java.net/glassfish/eclipse

Double click downloaded file to create pkg file.

Double click on .pkgfile to start Installer wizard.
Welcome Message is displayed.

Click Continue.
License Agreement page is displayed.
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Read and accept License Agreement. Click Install.

Accept default location or enter a different location to install software.
For example: HD Disk.

Click Install.
Wait for installation to complete.

Click Close.

To start the IDE, navigate to Applicationsdirectory and click GlassFish Tools Bundle for Eclipse
<version>.
Workspace Launcher page is displayed.

Accept the default Workspace location or enter a different location.

Click Next.
GlassFish Registration page is displayed.

Register GlassFish Server from Registration Screen.
You can also choose one of the other registration options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish depending on the option you chose in the previous screen.
Eclipse IDE is opened.

Close Welcome page to enter default Workbench, in Java EE Perspective.

▼ To Install on Linux Platform
Download Linux version of GlassFish Tools Bundle for Eclipse from the following location:
http://download.java.net/glassfish/eclipse

Move the jar file to a suitable directory.
If you are using the zipped tar file then skip Steps 3 through 18 and go to Step 19.

Use the following command to start the installer wizard:
java -jar <glassfish-tools-bundle-for-eclipse-xxxx.jar>
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Welcome Message is displayed.

Click Next.

License Agreement page is displayed.

Read and accept License Agreement. Click Next.

Target Path selection page is displayed.

Accept default location or enter a different location to install software.

For example: /home/<GlassFishBundle>

Click Next.

Setup Shortcuts page is displayed.

Use checkbox to create or not to create shortcuts for the application in the Start (XDG-Menu).
Select default Program Group for shortcuts or create a new Program Group.

Click Next.

Summary Configuration Data page is displayed.

If configuration data is correct, click Next.

Wait for installation to complete.

Click Next.

Installation Finished message is displayed.

Click Done.

Navigate to the install location, <glassfish-tools-bundle-for-eclipse-xxxx> directory.

This directory contains Eclipse IDE 3.5.x, GlassFish Server v3 installations.

Start the IDE, by using the following command:

./eclipse

Workspace Launcher page is displayed.

Accept default Workspace or enter a different Workspace.

Click OK.

GlassFish Registration page is displayed.
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Register GlassFish Server from Registration Screen.
You can also choose one of the other available options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish depending on the option you chose in the previous screen.
The IDE is opened.

Close Welcome page to enter default Workbench, in Java EE Perspective.

If you are using the zipped tar file (tar.gz) distribution, then use the following step to install:

■ Use gunzip and then extract tar file.
When file is extracted, Eclipse IDE 3.5.x and GlassFish Server v3 along with the plug-in that
integrates these products are installed on system.

■ Go to Step 13 and continue.

▼ To Install on Open Solaris Platform
Download Open Solaris version of GlassFish Tools Bundle for Eclipse from the following location:
http://download.java.net/glassfish/eclipse

Move the jar file to a suitable directory.
If you are using the zipped tar file then skip Steps 3 through 17 and go to Step 18.

Use the following command to start the installer wizard:
java -jar <glassfish-tools-bundle-for-eclipse-xxxx.jar>

Welcome Message is displayed.

Click Next.
License Agreement page is displayed.

Read and accept License Agreement. Click Next.
Target Path selection page is displayed.

Accept default location or specify a different location to install software.
For example: /home/<GlassFish-Tools-Bundle-For Eclipse-<version>/
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Click Next.

Setup Shortcuts page is displayed.

Use checkbox to create or not to create shortcuts for the application in the XDG-Menu. Select
default Program Group for shortcuts or create a new Program Group.

Click Next.

Summary Configuration Data page is displayed.

If configuration data is correct, click Next.

Wait for installation to complete.

Click Next.

Installation Finished message is displayed.

Click Done.

To start the IDE, select Launch->Applications->GlassFish Tools Bundle for Eclipse
<version>->GlassFish Tools Bundle for Eclipse.

Workspace Launcher page is displayed.

Accept default Workspace location or enter a different location.

Click OK.

GlassFish Registration page is displayed.

Register GlassFish Server from Registration Screen.

You can also choose one of the other available options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish depending on the option you chose in the previous screen.

Eclipse IDE is opened.

Close Welcome page to enter default Workbench, in Java EE Perspective.
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If you are using the zipped tar file (tar.gz) distribution, then use the following step to install:

■ Use gunzip and then extract tar file.
When file is extracted, Eclipse IDE 3.5.x and GlassFish Server v3 along with the plug-in that
integrates these products are installed on system.

■ Go to Step 13 and continue.

▼ To Uninstall
To uninstall your GlassFish Tools Bundle for Eclipse installation, use the following procedure:

For Windows installations, select Start->GlassFish Tools Bundle For Eclipse
<version>->GlassFish Tools bundle Uninstall.

For Mac OS installations, go to <Disk>/Applications directory, remove the
<installation>directory.

For Linux installations, go to <installation>/Uninstall directory and use the following
command to launch the Uninstaller:
java -jar uninstaller.jar

For Open Solaris installations, go to <installation>/Uninstall directory and use the
following command to launch the Uninstaller:
java -jar uninstaller.jar

Alternately, you can also use the Launch Menu to uninstall.

■ Select Launch->Applications->GlassFish Tools Bundle for Eclipse <version>->Uninstall.

▼ Troubleshooting
If you face any issues in installing the bundle, use the following steps to clean up the failed install
and restore the pre-installation state of system.

Remove the <installation>directory.

Remove any relevant hidden directories and files from your home directory.
For example: ~/.glassfish-tools-bundle-for-eclipse-<version> on Linux.

Remove the Eclipse Workspace associated with the installation, if configured.
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Configuring and Using GlassFish Server from
IDE

This chapter introduces you to configuring and using the GlassFish Server from Eclipse IDE.
When GlassFish Tools Bundle for Eclipse is installed successfully, you can configure it and take
advantage of advanced features available in GlassFish Server. The following topics describe the
process of configuring the GlassFish Server from the Eclipse IDE.

Several of the following procedures use Server popup menu. For more information on using the
Server popup menu, see Appendix A, “Using Popup Menu.”

■ “To create a New Server” on page 18
■ “To start GlassFish Server” on page 18
■ “To stop GlassFish Server” on page 19
■ “To restart GlassFish Server” on page 19
■ “To start GlassFish Server in Debug mode” on page 20
■ “To start GlassFish Server in Profile mode” on page 20
■ “To publish Projects” on page 21
■ “To clean published Projects” on page 21
■ “To add and remove Projects” on page 21
■ “To display GlassFish Sever properties” on page 22
■ “To access GlassFish Server Administration Console” on page 22
■ “To register GlassFish Server Installation” on page 23
■ “To access the GlassFish Update Center from Eclipse IDE” on page 23
■ “To update the Plug-In” on page 24
■ “To use Help Menu for GlassFish Server” on page 24
■ “To change Preferences for GlassFish Server Plug-in” on page 25
■ “To monitor TCP/IP for Web Applications with GlassFish Server” on page 26
■ “To view Sample JavaDB” on page 27
■ “Miscellaneous Information” on page 27

3C H A P T E R 3
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▼ To create a New Server
The GlassFish Tools Bundle for Eclipse, by default, installs a new instance of GlassFish v3 Server
for you. If you want to add a new Server to Eclipse IDE, use the following procedure.

To create a new Server instance, use the following procedure:

Select Servers view.

Select New, from Server popup menu.

New Server page is displayed

Provide GlassFish Server details.

For example, provide details for the following:

Server's host name

Server type

Server name

Server Runtime Environment

Click Next.

Complete Server configuration. For example, provide values for the following:

Domain Directory

Domain Name

Administrator ID

Administrator password

Click Next.

Add and Remove Projects page is displayed.

Select the existing projects, you want to add to the new Server.

Click Finish.

New Server creation is completed.

▼ To start GlassFish Server
To start your GlassFish Server from Eclipse IDE, use the following procedure:
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Note – By default, Eclipse Workbench is set to Java EE Perspective. Skip Step 1 if Workbench is
already set to Java EE Perspective.

Select Window->Open Perspective->Java EE Perspective, to set Eclipse IDE to Java EE
Perspective.

Select Servers view.

Select the GlassFish Server instance you want to start.

Select Start from Server popup menu.
GlassFish Server is started.

Tip – You could also use the Start icon from the toolbar to start Server.

Tip – If you are on Mac platform, make sure the default JDK on your system is 1.6. Otherwise the
bundled GlassFish v3 server will not start.

▼ To stop GlassFish Server
To stop a running GlassFish Server, use the following procedure:

Select Servers view.

Select the GlassFish Server instance you want to stop.

Select Stop from Server popup menu.
GlassFish Server is stopped.

Tip – You could also use the Stop icon from the toolbar to stop the Server.

▼ To restart GlassFish Server
To stop and restart a running GlassFish Server, use the following procedure:

Select Servers view.

Select the GlassFish Server you want to restart.

1

2

3

4

1

2

3

1

2

Chapter 3 • Configuring and Using GlassFish Server from IDE 19



From Server popup menu, select Restart.

GlassFish Server is stopped and restarted.

▼ To start GlassFish Server in Debug mode
When you want to debug an application, run GlassFish Server in debug mode, . To start
GlassFish Server in debug mode, use the following procedure:

Select Servers view.

Select the GlassFish Server.

Right click and select Debug from Server popup menu.

GlassFish Server is started in Debug mode.

Note – If GlassFish Server is already running, you will see Restart in Debug option in the
popup menu, instead of Debug.

For more information on using GlassFish Server to debug applications, see “To debug a Servlet
with GlassFish Server” on page 32.

▼ To start GlassFish Server in Profile mode
This option allows the GlassFish Server to start in Profile option. The Profile options refers to
Eclipse Profiler. This option is available only on Windows platform. You also need to configure
the profile of the server before using this option. For more information, see Eclipse Profiler.

Select Servers view.

Select the GlassFish Server.

Right click and select Profile from Server popup menu.

GlassFish Server is started in Profile mode.

Note – If GlassFish Server is already running, you will see Restart in Profile option in the
popup menu, instead of Profile.
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▼ To publish Projects
To publish applications to the GlassFish Server, use the following procedure:

Select Servers view.

Select GlassFish Server.

Right click and select Publish from Server popup menu.
The selected applications are published to the GlassFish Server.

▼ To clean published Projects
To discard all published projects, and republish from scratch, use the following procedure:

Select Servers view.

Select GlassFish Server.

Select Clean... from Server popup menu.

Click OK to accept the warning regarding discarding the published state.
The published state of projects is discarded and projects are republished.

▼ To add and remove Projects
To add and remove projects that are configured to run on GlassFish Server, use the following
procedure:

Select Servers view.

Select GlassFish Server.

Select Add and Remove Projects... from Server popup menu.
Add and Remove Project screen is displayed.

To add a project to Server:

a. Select the project you want to add from Available projects panel.

b. Click Add, to add the project to Configured projects panel.
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To remove a project from Server:

a. Select the project you want to remove from Configured projects panel.

b. Click Remove, to remove the project and move it to Available projects panel.

Click Finish to exit.

▼ To display GlassFish Sever properties
To view some of the GlassFish Server current properties and/or to restore them to default, use
the following procedure:

Select Servers view.

Select GlassFish Server.

Select Properties from Server popup menu.
Properties for GlassFish Server page is displayed.

View current Server properties or restore them to default.

▼ To access GlassFish Server Administration Console
GlassFish Sever offers many administrative features that are not accessible from Eclipse IDE.
These features are available from GlassFish Server Administration Console which is accessible
from Eclipse IDE. The following procedure describes the process of accessing GlassFish Server
Administration Console, from Eclipse IDE.

For more information on how to access GlassFish Server popup menu, see Appendix A, “Using
Popup Menu.”

Make sure that GlassFish Server is running while performing this task.

Open Eclipse IDE.
Default Workbench is displayed.

Select Servers view.

Select Server popup menu →GlassFish Enterprise Server→GlassFish Administration Console.
GlassFish Administration Console is displayed.
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Access various features available from Administration Console such as Registration,
Subscription and Documentation.

▼ To register GlassFish Server Installation
By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

If you did not register during installation, use the following procedure to register your GlassFish
Server from Eclipse IDE.

Make sure that GlassFish Server is running while performing this task.

For more information on GlassFish Server popup menu, see Appendix A, “Using Popup Menu.”

To view Registration page, from Server popup menu select GlassFish Enterprise Server
→Register GlassFish Enterprise Server.

Provide the required information to register your GlassFish Server Installation.
When you are registered you can access GlassFish Server support information. Use the next
steps to access registration.

To access Support Information, from GlassFish Server popup menu, select →GlassFish
Enterprise Server→Get Support for GlassFish Enterprise Server.

▼ To access the GlassFish Update Center from Eclipse IDE
The GlassFish Update Center provides access to Add-On components and product updates for
GlassFish Server.

Use the following procedure to access GlassFish Update Center from Eclipse IDE.

Note – You can update the GlassFish plug-in inside the bundle, by accessing Help→Check for
Updates option. For more details see the next section.

Make sure that the GlassFish Server is running while performing this task.

For more information on how to access GlassFish Server popup menu, see Appendix A, “Using
Popup Menu.”

Select GlassFish Enterprise Server→GlassFish Update Center from Server popup menu.

Before You Begin
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Select Add-On components and product updates as required.
For example: JRuby.

▼ To update the Plug-In
The GlassFish plug-in module installed with the bundle can be updated with the latest version.
Before you access the plug-in software, you need to configure you bundle for checking for
updates from the repository. Do the following steps to configure the repository for the first time.

Select Window→Preferences.

Select Install/Update→Available Software Sites.

Select the plug-in site from the Available Software Sites list:
https://ajax.dev.java.net/eclipse

Click Test Connection button to verify access to the site.

Click Enable to enable the downloads from the site.

Click OK to exit the window.
You configuration is now completed.

Select Help→Check for Updates.

Select the Updates you want to install select the check box next to it.

Click Next.

If the updates are confirmed then click Next. Otherwise click Back to select or deselect options.

Accept the terms of Licence by selecting the relevant radio button.

Click Finish to start installing the plug-in update.

▼ To use Help Menu for GlassFish Server
The GlassFish Tools Bundle for Eclipse, provides additional GlassFish help options from the
Eclipse IDE Help menu. You can access the Online Help for GlassFish Server v3, v3 Prelude and
v2.1 from Eclipse IDE Help->GlassFish Enterprise Server menu. The Help options are useful
for learning how to use, administer or deploy with GlassFish server.

Use the following procedure to access Eclipse Help menu:
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Select Help->Java EE 6 Javadoc to view Java EE 6 Javadocs online.

Select Help->Java EE 5 Javadoc to view Java EE 5 Javadocs online.

Select Help->GlassFish Enterprise Server, to view GlassFish Server help options.

The following options are available:

■ Get Support for GlassFish Enterprise Server

■ Aquarium: GlassFish Community News

■ GlassFish v3 (Link to documentation)

■ GlassFish v3 Prelude (Link to documentation)

■ GlassFish v2.1 Java EE 5 (Link to documentation)

▼ To change Preferences for GlassFish Server Plug-in
The GlassFish Tools Bundle for Eclipse allows you to change the preferences for GlassFish
Server plug-in from Eclipse IDE.

To change GlassFish plug-in preferences from Eclipse IDE, select Window->Preferences.

The available GlassFish Server preference flags are explained in detail.

■ Enable GlassFish Plug-in Log information in IDE log file

This preference is useful for debugging purposes. By turning this option on, you can see
additional traces in Eclipse log file specific to GlassFish plug-in. This option is in OFF state by
default.

■ Start the JavaDB database process when Starting GlassFish Server

GlassFish Tools Bundle for Eclipse includes a preconfigured JavaDB Database. By turning
this option on, you can start the database automatically when the server is started. It is useful
when working with JPA applications. This option is in OFF state by default.

■ Start the GlassFish Enterprise Server in Verbose Mode

By turning this option on, GlassFish server output log is sent to Eclipse console. This option
is in OFF state by default.
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■ Enable colored rendering in GlassFish Log Viewer
By turning this option on, log messages can be rendered in color: INFO level messages in
black, WARNING messages in yellow, SEVERE messages in red (Eclipse IDE default Error
Text color), and multiple line entries in Italic. This option is in ON state by default.

Tip – You an always modify Eclipse IDE Error message text color. Select
Window→Preferences→General→Appearance→Colors and Fonts. From Colors and
Fonts panel, select Basic and then Error Text color. Modify error text color as per your
requirement.

▼ To monitor TCP/IP for Web Applications with GlassFish
Server
TCP/IP monitoring is a useful Eclipse IDE feature that is enabled for GlassFish Server in this
bundle. It allows you to trace HTTP requests made to your web application. Use the following
procedure to configure TCP/IP monitoring for GlassFish Server.

From GlassFish Server popup menu, select Monitoring->Properties.
Monitoring Properties page is displayed.

Click Add.
Monitoring Ports page is displayed.

Select Server Port, which is the http port used by GlassFish server.
By default, it is 8080. The port that will be used to actually do monitoring is 8081 which is
specified in the Monitor Port field.

Note – You can modify port numbers as necessary.

Click Start, to start monitoring.
The port 8080 is now monitored from port 8081.

The Status column in page will show (monitoring) status as Started.

Select Apply and then OK, to complete setup.
When GlassFish server is running, access a web page using port 8081 instead of the regular port
8080. The TCP/IP monitor view should appear below, and fill up with the traffic between your
Web browser and your web application. When you select each request in the tree at the top left
of page, information about the request/response is shown. The bottom left of the view will
display the HTTP request that was made to your web application, and the bottom right will
show each response.
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▼ To view Sample JavaDB
The GlassFish Tools Bundle for Eclipse, by default, installs and creates a JavaDB sample
database for you.

Use the following procedure to view the tables that exist in the database. Skip Step 1 to Step 5 if
the database is already started.

Select Window→Preferences.
Preferences page is displayed.

Select GlassFish Preferences.

Select the Checkbox next to Start JavaDB database process when Starting GlassFish Server
option.

Click Close.

Restart the GlassFish Server.
The sample JavaDB database will be started along with the GlassFish Server.

Select Data Source Explorer view.

Select Sample JavaDB database node.

Right click the node to view the popup menu and confirm if the Database is connected.

If not, select Connect from the popup menu.
You will be connected to the Database.

Click to expand the database node.
You will be able to see the various schemata and tables that are already created for you.

▼ Miscellaneous Information
The above procedures describe the use of Server popup menu for various tasks, such as starting
and stopping GlassFish Server.

The same tasks can also be performed using other menus such as Eclipse IDE toolbar menu or
Project node right click menu. You can use any of the available menus as is convenient.

For example, starting the Server in Debug mode as described in “To debug a Servlet with
GlassFish Server” on page 32, can also be done from Eclipse toolbar menu.

1

2

3

4

5

6

7

8

9

10

Chapter 3 • Configuring and Using GlassFish Server from IDE 27



Select the Project in Project Explorer.

Select Debug As.
Menu is displayed.

Select Debug As icon from toolbar.

a. Select Run on Server.
Debug On Server page is displayed.

b. Select Bundled GlassFish Server v3.

c. Click Next to continue.

d. Select any other Projects you want to Debug.

e. Click Finish.
Prompt to Switch mode is displayed.

f. Select Switch Mode option and click OK.

For more information on Eclipse IDE menus, see Eclipse Documentation.
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Developing Applications for GlassFish Server

This section of the document helps you to get familiar with developing applications for
GlassFish server with Eclipse IDE, using the advanced features available in GlassFish Server v3.

The following topics assume GlassFish Server v3 as server runtime. You can also use GlassFish
Server v2.1 for developing applications but without support for the features that are specific to
v3. You may also need to perform further configuration, for the following tasks to work with
GlassFish Server v2.1.

For example: Use of EclipseLink described in “To create a new Data Source and register it with
GlassFish Server” on page 33, is preconfigured to work with GlassFish Server v3 but not with
GlassFish Server v2.1.

■ “To create a new Web Application project for GlassFish Server” on page 29
■ “To add a Servlet and use Session Preservation feature” on page 30
■ “To debug a Servlet with GlassFish Server” on page 32
■ “To edit the preconfigured MySQL Database Connector” on page 33
■ “To create a new Data Source and register it with GlassFish Server” on page 33
■ “To create a JPA Project for GlassFish Server” on page 35

▼ To create a new Web Application project for GlassFish
Server
You can create different types of applications using GlassFish Tools Bundle for Eclipse. The
following procedure describes the process of creating a Web Application for publishing to
GlassFish Server.

Select File->New->Dynamic Web project.

Project creation page is displayed.

4C H A P T E R 4

1

29



Enter a Project Name in the first field.
For example: MyFirstWebApp.

Select GlassFish Server version to use as Target Runtime.
For example: GlassFish v3 Server.

Click Finish.
A new dynamic Web Project is created and is visible in Project Explorer panel.

A default JSP file index.jsp page is created and opened in JSP Editor View.

Add or modify index.jsp code as required.

From Eclipse main menu, select Run menu or Run icon from toolbar.

Select Run On→GlassFish Server v3, as the server to run this application.

Note – You can select Always use this server when running this project checkbox to streamline
further run invocations.

Build the Web Application and publish to GlassFish Server v3.
The Console view displays server log. The index.jsp page appears in Eclipse IDE default Web
Browser.

Note – You can always switch back and forth between Editor view and Web Browser view. Both
views are available from Eclipse Editor. Each time the application is changed, it is redeployed on
server. You can reload the application in the browser to see the changes immediately.

▼ To add a Servlet and use Session Preservation feature
Session Preservation is convenient feature available from GlassFish Server v3, which is critical
when developing/debugging complex Web Applications with complex Session management
such as Shopping Cart applications, and when you want to retain information about your
Sessions across redeployments.

This section of document explains how to use Session Preservation feature. For testing this
feature, you can use the Project created in the previous example or create a new Project. If you
are using the previously created project, skip Step 1.

This section of the document is applicable for GlassFish Server v3 only. It is not applicable to
GlassFish Server v2.1.
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Create a new Dynamic Web Project, in the manner described in the previous section.

From Project Explorer window, right click the Project node.

Select New->Servlet, to create a new servlet.
Create Servlet screen is displayed.

Enter a package name.
For example: apkg.

Enter a servlet name.
For example:MyServlet

Click Finish.
A new servlet is created and opened in Eclipse IDE editor view.

From Eclipse IDE editor, add more logic to the servlet.
An example Servlet code for showing Session data is available from here:Sample Servlet code for
Session Preservation

Save servlet file.
The file is deployed on the GlassFish Server.

Go to Web Browser view to activate the servlet page.
http://localhost:8080/MyFirstWebApp/MyServlet.

Reload servlet web page, a number of times.
In the servlet page, you can see the Number of Previous Accesses field growing. This counter is
stored in Servlet Session data.

Modify servlet source code, and redeploy the web application.
Go the Web Browser view and click Reload to see the updated page.

Tip – By default, Deploy On Save mode is enabled. When you save servlet source file, it is
automatically redeployed on the server.

To test Session Preservation feature, add some text in servlet source code.
For example:
session.putValue("accessCount", accessCount);

out.println (

..............
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..............

"<H2> Updated Servlet!!! Information on your Session:<H2>\n"+
..............

..............

and save the servlet page.

When the update is saved, the servlet is redeployed.

Access the web page once again.

You can see the newly added text, Updated Servlet!!! in the web page, and the field, Number
of Previous Accesses, as 5.

With the above process you have verified that the Servlet Session data was preserved during
redeployment.

▼ To debug a Servlet with GlassFish Server
GlassFish Tools Bundle for Eclipse enables you to debug various types of web applications such
as servlet helper classes, JPA (Java Persistence API) applications, Web Services, or JSP pages
containing Java code fragments. The following procedures describes the process of setting up a
servlet for debugging.

Set breakpoints for an application.

Go relevant line of application code from Eclipse IDE editor.

Select Run->Toggle Break Point.

■ You can also select the popup menu available in the vertical grey bar, on the left side of
Eclipse IDE editor, and select Toggle Break Point.

If Eclipse IDE can set up a breakpoint on this selected line, a small icon will appear on the vertical
grey bar.

If Eclipse IDE cannot set a breakpoint on this line, you will be notified.

Select Debug from Server popup menu to start GlassFish server in debug mode.

Eclipse IDE will switch to Debug Perspective as soon as the Web Page with breakpoint set, is
activated.

You can now start to debug the servlet using the feature-rich Eclipse Debugger.
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Note – For debugging a project, you can always use the Debug As icon from the Menu toolbar or
the Debug As option from the Project node right click menu.

For more information on using the Eclipse IDE, use the Help Menu.

▼ To edit the preconfigured MySQL Database Connector
The GlassFish Tools Bundle for Eclipse includes a preconfigured MySQL database connector.
You can use it to connect with your MySQL database with minimal configuration effort.

To edit the preconfigured MySQL database connector, use the following process:

From Eclipse IDE, select Windows->Preferences

Select Data Management from left-hand side panel.

Click Connectivity

Click Driver Definitions.

Select MySQL JDBC Bundled Driver Default and click Edit.

Edit the parameters for the MySQL Driver Definition as required.

Click OK to close dialog box.

Click OK to close Preferences screen.

▼ To create a new Data Source and register it with
GlassFish Server
As described in Chapter 3, “Configuring and Using GlassFish Server from IDE,” by default
GlassFish Tools Bundle for Eclipse installs and configures a Derby database instance for you.

You can also create a new Data Source and register it with GlassFish Server from Eclipse IDE.
The process of creating and registering a new MySQL Data Source is described as follows:

Install a MySQL database instance if you do not have a pre-installed MySQL database. For more
information on installing MySQL, See MySQL installation documentation.

Select Database Connections from Data Source Explorer view. Right click the Databases node
and select New.
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Select MySQL from New Connection Profile options.

Accept default name, New MySQL or choose another name.

Click Next.

MySQL Connection Profile screen is displayed.

Click New Driver Definition button (located next to Drivers text box).

New Driver Definition screen is displayed.

Note – Steps 5 through 9 are optional and are required only if you need to use a MySQL driver
that is not bundled.

Download and save the new MySQL driver file into the bundle. For example:

In <glassfish-tools-bundle-for-eclipse-xxxx>/mysql-driver directory.

Select a Driver template from list.

Select Jar List tab, and select location of new MySQL JDBC Driver file: For example:

<glassfish-tools-bundle-for-eclipse-xxxx>/mysql-driver/mysql-connector-java-xxxx.jar

directory.

Select Properties tab and view properties of Driver Definition.

Change any properties as required.

Click OK to exit New Driver Definition screen.

From Connection Profile screen, modify any other details as required.

For example: User name and Password.

Click Test Connection to test Database connectivity.

Click Next to view a summary of Connection Profile.

Verify Profile details.

If necessary, go back and change details.

Click Finish to complete creation of the new Data Source profile.

The newly created MySQL Data Source can be seen from Data Source Explorer view.
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Note – You can also edit Data Resources from GlassFish Server Administration Console.

Additional details on editing Data Resources are available from GlassFish Server
Administration Documentation.

▼ To create a JPA Project for GlassFish Server
The following steps explain how to create a Java Persistence API (JPA) based project and
generate DDL for it.

This section of the document is applicable for GlassFish Server v3 only. It is not applicable to
GlassFish Server v2.1.

Select Window->Preferences.
Preferences page will be displayed.

Select GlassFish Server Preferences.

Select the checkbox next to Start JavaDB database process when Starting GlassFish Server
option.

Click OK to close the page.

Start or restart GlassFish Server.
The JavaDB database is started along GlassFish Server.

Select File->New->Other.
New project wizard will be displayed.

Select JPA->JPA Project.

Click Next to continue.
New JPA Project wizard will be displayed.

Create a name and select to run on GlassFish Server v3.
For example:MyJPAProject.

Click Next to continue.

Select EclipseLink as Platform and Sample JavaDB Database as connection.

Before You Begin

1

2

3

4

5

6

7

8

9

10

11

Chapter 4 • Developing Applications for GlassFish Server 35



Select Annotated classes must be listed in persistence.xml option, for Persistent class
management.
Other default options need not be changed.

Click Finish to complete new JPA project creation.

Accept message prompt to switch to JPA perspective.

Select File->New->Other.
New project wizard will be displayed.

Select JPA->Entity.

Create a name and package name.
For example: MyEntity

Click Next to continue.

Add two fields in the Entity Fields panel, one of which should be selected as key field.
For example: Type=Int:Fieldname=id, Type=String:Fieldname=name.

Click Finish.
A New Entity Class is created

Right click on JPA Project Node and select JPATools->Generate DDL.

Click OK to warning that you are about to create new tables.
New tables will be created in database.

Select Data Source Explorer.

Select the Sample JavaDB database.
You can view the newly created tables by expanding the Sample JavaDB Database node.
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Using Java EE 6 Wizards

While Java EE 6 support in Eclipse is not yet available, you can develop applications for Java EE
6 platform, using the GlassFish Tools Bundle for Eclipse which can be deployed on the bundled
GlassFish v3 server.

GlassFish Tools Bundle for Eclipse supports several Java EE 6 wizards, to create applications
that can be deployed on the GlassFish v3 server. Some of these new Java EE 6 wizards are similar
to the Java EE 5 wizards frequently used by Eclipse IDE users such as Servlet and Session Bean
wizards.

Some of the wizards offer new functionality for Java EE 6 platform such as EJB Timer and
XHTML Page wizards. This chapter contains information on how to use these wizards.

■ “To create a Web Project” on page 37
■ “To create a Web Servlet Class” on page 38
■ “To create a Web Filter Class” on page 39
■ “To create Web Listener Class” on page 39
■ “To create a Session Bean Class” on page 40
■ “To create an EJB Timer Class” on page 41
■ “To create an XHTML Page” on page 42
■ “To create a RESTful Web Service Class” on page 42

▼ To create a Web Project
Select File->New->Dynamic Web Project.

The New Dynamic Web Project wizard opens.

Enter the name of the project in the Project name field.

For example: MyWeb.
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Click Next.

Configure project screen is displayed.

Click Next.

Configure web module settings screen is displayed.

Click Finish.

A new web project is created and opened in the Project Explorer panel.

▼ To create a Web Servlet Class
Select the web project created in the previous task, MyWeb.

Right click and select New->Web Servlet (Java EE 6).

The Create Servlet wizard opens.

Enter the following information into the fields:

a. Enter Java package name. For example: mypkg.

b. Enter Class name. For example: MyServlet.

Note – If you are not customizing your default configuration options, you can skip Steps 4 and 5
and proceed to Step 6.

Click Next.

Servlet deployment descriptor modification screen is displayed.

Click Next.

Create modifiers, interfaces, and method stubs generation screen is displayed.

Click Finish.

A new servlet class, MyServlet.java is created and opened in the editor.
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▼ To create a Web Filter Class
Select the web project created in the earlier task, MyWeb.

Right click and select New->Web Filter (Java EE 6).

The Create Filter wizard opens.

Enter the following information into the fields:

a. Enter Java package name. For example: mypkg.

b. Enter Class name. For example: MyFilter.

Note – If you are not customizing your default configuration options, you can skip Step 4 and 5
and proceed to Step 6.

Click Next.

Servlet deployment descriptor modification screen is displayed.

Click Next.

Create modifiers, interfaces, and method stubs generation screen is displayed.

Click Finish.

A new filter class, MyFilter.java is created and opened in the editor.

▼ To create Web Listener Class
Select the web project created in the earlier task, MyWeb.

Right click and select New->Web Listener (Java EE 6).

The Create Listener wizard opens.

Enter the following information into the fields:

a. Enter Java package name. For example: mypkg.

b. Enter Class name. For example: MyListener.

Click Next.
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Select application lifecycle events to listen from the check boxes. You must select at least one
event.

For example: Select Changes to Attributes from HTTP Session Events panel and Changes to
Attributes from Servlet Request Events panel.

Note – If you are not customizing your default configuration options, you can skip Step 6 and
proceed to Step 7.

Click Next.

Create modifiers, interfaces, and method stubs generation screen is displayed.

Click Finish.

A new listener class, MyListener.java is created and opened in the editor.

▼ To create a Session Bean Class
You can create any type of session bean with this wizard. You may note that some new options:
Singleton (Step 3c — drop-down list)) and No Interface (Step 3d — Check Box), are available in
this Java EE 6 wizard.

Select the web project created in the earlier task, MyWeb.

Right click and select New->Session Bean (Java EE 6).

Create EJB 3.1 Session Bean wizard opens.

Enter the following information into fields:

a. Enter Java package name.

For example: mypkg.

b. Enter Class name.

For example: NoInterfaceStateLess.

c. Choose State Type from drop-down list.

For example: Stateless

d. Choose Create business interface:

For example: select the check box for No-interface option.
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Note – If you are not customizing your default configuration options, you can skip Steps 4 and 5
and proceed to Step 6.

Click Next.

Select Transaction Type.

For example: Container.

Click Finish.

A new Java Session bean class, MySessionbean.java is created and opened in the editor.

Tip – Depending on your options, you may create more than one file when using the Create
Session bean wizard.

Create other types of Session Beans in a similar way but with different options such as stateful or
singleton state types and with remote or local interfaces.

▼ To create an EJB Timer Class
Select the web project created in the earlier task, MyWeb.

Right click and select New->EJB Timer (Java EE 6).

Create EJB Timer Callback wizard opens.

Enter the following information into fields:

a. In Source folder field, select default or enter a new folder name.

For example: MyWeb\src.

b. In the Java package and the Class name fields, enter information.

For example: mypkg and MyTimer respectively.

Click Finish.

A new EJB class MyTimer.java is created and opened in the editor.
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▼ To create an XHTML Page
Select the web project created in the earlier task, MyWeb.

Right click and select New->XHTML.
Create XHTML page wizard opens.

Enter the following information into fields:

a. Enter or select the parent folder.
For example: MyWeb/WebContent

b. Enter the File name.
For example: MyTemplate

Click Next.

Select a HTML Template type.
For example: New Facelet Template

Click Finish.
A new XHTML page, MyTemplate.xhtml is created and saved under MyWeb/WebContent folder.

▼ To create a RESTful Web Service Class
Select the web project created in the earlier task, MyWeb.

Right click and select New->RESTful Web Service (Java EE 6).
Create RESTful Web Service wizard opens.

Enter the following information into fields:

a. Enter or select the package name:
For example: mypkg

b. Enter the File name:
For example: MyRESTfulWS

Select the Pattern type from drop-down list:
For example: Single Root Resource
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Note – The other available pattern types are Container-Item and Client-Controlled

Container-Item. If you select one of these two options, an additional Java class will be created
instead of one class as described in the next step.

Click Finish.
A new Web Service class, MyRESTfulWS.java is created and opened in the editor.
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Getting Started with Metro

Metro is a high-performance, extensible, easy-to-use Web Service stack that is a part of
GlassFish Server community. It offers core support for JAX-WS and optionally support for
additional features.

The GlassFish Tools Bundle for Eclipse 1.1 version includes Metro plug-in for Eclipse.

Developing Web Applications using Metro
This section of the document will help you get familiar with developing web services
applications with Metro using the Tools Bundle.

Install Metro on GlassFish Server
Before you can start developing web application with Metro for GlassFish Server, you need to
ensure Metro is installed on GlassFish Server.

While GlassFish v2.1 includes Metro, GlassFish v3 does not include the Metro stack by default.
You can install it as an Add-On package.

You can also update Metro version included with GlassFish Server v2 as described in the
following document:

https://metro.dev.java.net/1.4/docs/install.html

▼ To install Metro for GlassFish Server v3
Metro is available as an Add-On package from Update Center for GlassFish v3. The following
task describes the process of adding Metro stack to GlassFish v3.

Stop GlassFish v3 Server.
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Start the Update Tool from <install-location>/glassfishv3/bin directory.

Click available Add-Ons.

Select Metro Web Services for GlassFish.
Optionally you can also select Jersey Web Services.

Click Install.

Accept License Agreement.
Selected packages will be installed.

Start the GlassFish v3 Server.

Note – You can also use the Update Tool from GlassFish Server Administration Console for
installing Metro packages. If you are using the Update Tool from GlassFish Administration
Console, make sure the GlassFish Server is running and the Administration Console is installed.

▼ To create a new Metro based Web Service
The following task describes the steps to create a web application and add a web service to it.

Create a new web application as described in “To create a new Web Application project for
GlassFish Server”on page 29.

From Project Explorer, right-click the web application project node and select New->Class

In the New Java Class wizard, select mypkg as package name, and MyHelloService as class
name.

Click Finish.

In the Eclipse IDE, edit the java class file and enter the following code snippet to create a
method:
package mypkg;

public class MyHelloService {

public String sayhello(String name) {

return "Hello " + name;

}

}
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From the Project Explorer, select MyHelloService java class.

Right-click the java class and select WebServices->Create Web Service.

In the Service section, move the Service slider one level up to the top, to enable Test Service
stage.

Click Web Service runtime entry.

Select METRO Runtime in the dialog box.

Click OK to close the dialog box.

Your configuration will look like this:

Click Next.

Options screen is displayed. You can customize your options for:

■ Generation of JSR 109 portable /JAX-WS RI specific Web Service.
■ Packaging of Metro libraries in war file.

The default options are set based on your target runtime platform.

Click Next.
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Start the Server if necessary, depending on the state of Server.

Enter your GlassFish Server admin login name and password if requested.

Click Launch, when presented with option to launch Web Service testing facility.

Browser opens page where you can test the web service.

Click Finish to complete the wizard.

At this stage a web service has been created and deployed on the server.

Click sayHello link in the web page, and then click Add to add the parameter value.

Enter your name in the text field and click Go.

The service will respond with Hello $YOUR_NAME message.

Click Source link to see the SOAP communication.

The result shall look like this:
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▼ To create a new Metro based Web Service from WSDL

Download this WSDL file and save it in a suitable location.

Right-click the Web Project created in the previous task, in Project Explorer and select
NewOther.

Browse the Web Services category and select Web Service from Menu.

Click Next.

Select Top down Java bean Web Service and click Browse to choose the WSDL file.

Click OK to close the dialog box.

Enter the direct file link to your WSDL file from the web browser as follows:

file:///Users/admin/work/sources/eclipse/metro/docs/SearchWS.wsdl.

Click Web Service runtime option and select METRO Runtime from the dialog box.

Click OK.

Your configuration will look like this:
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Click Next.

Accept the default options and click Next.

Start the server if necessary, depending on the state of server.

Enter your GlassFish Server admin login and password if requested.

Click Finish to close the wizard.

The Web Service is created, but deployment to server fails, because implementation of the
service is missing.

Click the error message (light-bulb icon) next to the compilation error, and choose Add
Unimplemented Methods.

Implement the service method. An example Service method source is as follows:
package org.tempuri;

import javax.jws.*;

@WebService(wsdlLocation = "WEB-INF/wsdl/SearchWS.wsdl",
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serviceName = "WebSearchWS",
portName = "WebSearchWSSoap",
endpointInterface = "org.tempuri.WebSearchWSSoap")

public class WebSearchWSSoapImpl implements org.tempuri.WebSearchWSSoap {

public String search(String keyWord) {

return "Search Result for: " + keyWord;

}

}

Right-click the web project node, and select Run As->Run On Server to deploy the application.

Visit the web service URL from browser.

For example:

http://localhost:8080/MyFirstWebApp/WebSearchWS?Tester

Input a search string and click Search.

The result shall look like this:
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▼ Configure the Web Service Policies
Browse the WSDL of the web service, in the project you created in the previous task.

Right-click it and select Web Services->WS-Policy Configuration.

WS-Policy configuration dialog box is opened.

Select the Reliable Message Delivery checkbox and click OK to save the value and close the
dialog box.

Deploy the project again (Run As->Run On Server)
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Visit the service URL from web browser.

For example:
http://localhost:8080/MyFirstWebApp/WebSearchWS?Tester

Click the WSDL link to see the WSDL of the service.

Scroll down to see the policy definition:

Go back to the Tester page in browser, input a search string in the search box and click Search.

Notice the change in the soap communication:
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Additional Resources
The following resources provide additional information on Eclipse IDE and GlassFish Server.

■ Sun GlassFish Enterprise Server v3 Prelude Documentation

Additional Resources
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■ Sun GlassFish Enterprise Server 2.1 Documentation
■ Eclipse Documentation

Additional Resources
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Using Popup Menu

The popup menu available from Servers view provides a number of usage options, including
customized options for GlassFish Server. It is referred to as the Server popup menu in this
document. To access popup menu from Eclipse IDE, select Servers view, and right click mouse.

The following options are available from Server popup Menu:

New Allows user to add a new GlassFish Server instance to Eclipse.
The new server should be pre-installed. In some cases, this
option also downloads and installs a new Server. For example:
GlassFish v2.1

Open (F3) Allows user to access Server Overview page. The Server
Overview page allows user to view and modify some GlassFish
Server properties:
■ Specify hostname and other common settings
■ Edit Server configuration properties (Open launch

configuration)
■ Modify settings for Publishing
■ Specify time limit to complete Server operations
■ Edit some Server runtime properties

Note – Alternately, select and double-click the Server from
Servers view, to launch Server Overview page.

Show In (Shift+Alt+W) Allows user to direct GlassFish Server log messages to Console
or Debug windows. This option is also accessible through
(Shift+Alt+W) key action.

Copy (Ctrl+C) Allows user to copy GlassFish Server Instance. This option is
also accessible through (Ctrl+C) key action.
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Paste (Ctrl+V) Allows user to paste the copied GlassFish Server Instance.
This option is also accessible through (Ctrl+V) key action.

Delete (Delete) Allows user to delete selected GlassFish Server Instance from
configuration. This option is also accessible through Delete
button from keyboard.

Rename (F2) Allows user to rename GlassFish Server Instance. This option
is also accessible through the F2 function key.

Debug (Ctrl+Alt+D) Allows user to start GlassFish Server Instance in Debug mode.
This option is also accessible through (Ctrl+Alt+D) key
action.

Start (Ctrl+Alt+R) Allows user to start GlassFish Server Instance. This option is
also accessible through (Ctrl+Alt+R) key action.

Profile This option is not implemented in GlassFish Tools Bundle for
Eclipse.

Stop (Ctrl+Alt+S) Allows user to stop GlassFish Server Instance. This option is
also accessible through (Ctrl+Alt+S) key action.

Publish (Ctrl+Alt+P) Allows user to deploy the built applications to GlassFish
Server. This option is also accessible through (Ctrl+Alt+P)
key action.

Clean... Allows user to discard all published state from GlassFish
Server and republish from scratch.

Add and Remove Projects... Allows user to add or remove Projects that are configured to
run on GlassFish Server.

Monitoring Allows user to monitor GlassFish Server ports for access. This
is a feature available in GlassFish Server v3. You can select the
properties for monitoring from properties sub menu.

GlassFish Enterprise Server Allows user to access to the following additional sub menu
options:
■ GlassFish Update Center
■ Register the GlassFish Enterprise Server
■ Get Support for GlassFish Enterprise Server
■ Aquarium: GlassFish Community News
■ View Admin Console
■ View Log File

Properties (Alt+Enter) Allows user to view GlassFish Server properties and modify
some of them. This option is also accessible through
(Alt+Enter) key action.

Using Popup Menu

GlassFish Tools Bundle for Eclipse User Guide • December 200958


	GlassFish Tools Bundle for Eclipse User Guide
	Introduction
	

	Installing GlassFish Tools Bundle for Eclipse
	Installation
	To Install on Windows Platform
	To Install on Mac OS Platform
	To Install on Linux Platform
	To Install on Open Solaris Platform
	To Uninstall
	Troubleshooting


	Configuring and Using GlassFish Server from IDE
	
	To create a New Server
	To start GlassFish Server
	To stop GlassFish Server
	To restart GlassFish Server
	To start GlassFish Server in Debug mode
	To start GlassFish Server in Profile mode
	To publish Projects
	To clean published Projects
	To add and remove Projects
	To display GlassFish Sever properties
	To access GlassFish Server Administration Console
	To register GlassFish Server Installation
	To access the GlassFish Update Center from Eclipse IDE
	To update the Plug-In
	To use Help Menu for GlassFish Server
	To change Preferences for GlassFish Server Plug-in
	To monitor TCP/IP for Web Applications with GlassFish Server
	To view Sample JavaDB
	Miscellaneous Information


	Developing Applications for GlassFish Server
	
	To create a new Web Application project for GlassFish Server
	To add a Servlet and use Session Preservation feature
	To debug a Servlet with GlassFish Server
	To edit the preconfigured MySQL Database Connector
	To create a new Data Source and register it with GlassFish Server
	To create a JPA Project for GlassFish Server


	Using Java EE 6 Wizards
	
	To create a Web Project
	To create a Web Servlet Class
	To create a Web Filter Class
	To create Web Listener Class
	To create a Session Bean Class
	To create an EJB Timer Class
	To create an XHTML Page
	To create a RESTful Web Service Class


	Getting Started with Metro
	Developing Web Applications using Metro
	Install Metro on GlassFish Server
	To install Metro for GlassFish Server v3

	To create a new Metro based Web Service
	To create a new Metro based Web Service from WSDL
	Configure the Web Service Policies

	Additional Resources

	Using Popup Menu

